Your host needs to use PHP 7.3.10 or higher to run this version of Joomla!